
CSI Solution Demonstrates Use of These Features

n Base (Seismic) Isolation

n Diaphragm Constraint

n Ritz Vectors

n Dynamic Analysis

n Mode Shapes

n Link Elements

n Modal Nonlinear Time History Analysis
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Problem O Solution

1. Click the File menu > New Model command to access the New Model form.

2. Click the drop-down list to set the units to ..

3. Click the 3D Frame button  to access the 3D Frames form. In that form:

n Select Open Frame Building from the 3D Frame Type drop-down list.

n Type 2 in the Number of Bays, X edit box.

n Type 30 in the Bay Width, X edit box.

n Type 30 in the Bay Width, Y edit box.

n Uncheck the Restraints check box.

n  Click the + (plus) symbol beside the drop-down list to access the Frame Properties form. In that 
form: 

¡ Click the Import New Property button to access the Import Frame Section Property form.

¡ In the Frame Section Property Type drop-down list, select Steel.

¡ Click the I/Wide Flange button to access the Section Property File form. Select the 
SECTIONS.PRO file and click the Open button. A database form of available sections will 
display. In that form:

l Click the + (plus) symbol beside the Material drop-down list to access the Define 
Materials form. In that form:

l Highlight the A992Fy50 definition in the Materials display list and click the 
Modify/Show Material button to access the Material Property Data form. In that 
form:

n Set the Units to .

n Verify that the Modulus of Elasticity is 29000 and the Poisson's Ratio is 0.3.

n Click the OK button on the Material Property Data form to return to the 
Define Materials form.

l Highlight the 4000Psi definition in the Materials display list and click the 
Modify/Show Material button to access the Material Property Data form. In that 
form:

n Set the Units to .

n Verify that the Weight per Unit Volume is 0.15.

n Click the OK buttons on the Material Property Data form and the Define 
Materials form to return to the database form.

l In the database form, ensure that the A992Fy50 definition is selected in the Material
drop-down list.
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l Scroll down the list of section, and while holding down the Ctrl key, click on the 
W14X90 section and the W24X55 section to select them.

l Click the OK button to access the I/Wide Flange Section form. 

l Click the OK buttons on the I/Wide Flange Section form and the Frame Properties
form to close those forms and return to the 3D Frame form.

n Ensure that the W24X55 section is selected in the Beams drop-down list and the W14X90 section 
is selected in the Columns drop-down list.

n Click the OK button on the 3D Frame form to close the form and display the template model in the 
program windows.

4. Click the drop-down list in the status bar to change the units to . 

5. Click the Define menu > Section Properties > Area Sections command to access the Area Sections
form. 

n In the Select Section Type to Add drop-down list, select the Shell option. 

n Click the Add New Section button to access the Shell Section Data form. In that form:

¡ Type ROOF in the Section Name edit box.

¡ In the Type area verify that the Shell-Thin option is selected.

¡ Ensure that 4000Psi is selected in the Material Name drop-down list.

¡ Type 6 in the Membrane edit box.

¡ Type 6 in the Bending edit box.

¡ Click the OK button to return to the Area Sections form.

n Click the Add New Section button to access the Shell Section Data form. In that form:

¡ Type FLOOR in the Section Name edit box.

¡ In the Area Type area, verify that the Shell-Thin option is selected.

¡ Ensure that 4000Psi is selected in the Material Name drop-down list.

¡ Type 10 in the Membrane edit box.

¡ Type 10 in the Bending edit box.

¡ Click the OK buttons on the Shell Section Data and Area Sections forms to close all forms.

6. Click the Define menu > Section Properties > Link/Support Properties command to access the 
Link/Support Properties form. In that form:

n Click the Add New Property button to access the Link/Support Property Data form. In that form:

¡ Select Rubber Isolator from the Link/Support Type drop-down list.

¡ Type RUB1 in the Property Name edit box.

¡ Type .001 in the Mass edit box.

¡ Check the U1 Direction check box in the Directional Properties area.

¡ Click the Modify/Show For U1 button to access the Link/Support Directional Properties
form. In that form:

l Type 10000 in the Effective Stiffness edit box.
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l Click the OK button to return to the Link/Support Property Data form.

¡ Check the U2 Direction check box.

¡ Check the U2 Nonlinear check box.

¡ Click the Modify/Show For U2 button to access the Link/Support Directional Properties
form. In that form:

l In the Properties Used for Linear Analysis Cases area, type 1.5 in the Effective 
Stiffness edit box.

l In the Properties Used for Nonlinear Analysis Cases area, type 10 in the Stiffness
edit box.

l Type 5 in the Yield Strength edit box.

l Type .2 in the Post Yield Stiffness Ratio edit box.

l Accept the other values on the form.

l Click the OK button to return to the Link/Support Property Data form.

¡ Check the U3 Direction check box.

¡ Check the U3 Nonlinear check box.

¡ Click the Modify/Show For U3 button to access the Link/Support Directional Properties
form. In that form:

l In the Properties Used for Linear Analysis Cases area, type 1.5 in the Effective 
Stiffness edit box.

l In the Properties Used for Nonlinear Analysis Cases area, type 10 in the Stiffness
edit box.

l Type 5 in the Yield Strength edit box.

l Type .2 in the Post Yield Stiffness Ratio edit box.

l Accept the other values on the form.

l Click the OK buttons on the Link/Support Directional Properties, Link/Support 
Property Data, and Link/Support Properties forms to exit all forms.

7. Click the Define menu > Load Patterns command to display the Define Load Patterns form. In that form:

n Type LIVE in the Load Pattern Name edit box.

n Select LIVE from the Type drop-down list.

n Click the Add New Load Pattern button.

n Click the OK button.

8. Click the drop-down list in the status bar to change the units to .

9. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. The window is active when its 
title is highlighted.

10. Click the Move Up in List button  until the plan display is moved up to the X-Y Plane @ Z=24.

n Click the Quick Draw Area Element button  (or the Draw menu > Quick Draw Area
command) to access the Properties of Object form. Select Roof from the Section drop-down list.

Page 4 of 11Problem O

10/4/2018mk:@MSITStore:C:\Program%20Files%20(x86)\Computers%20and%20Structures\SAP2...



n Click once in each of the four quadrants in the plan view to draw four roof area objects.

11. Click the Move Down in List button  to move the plan display down to the X-Y Plane @ Z=12.

n In the Properties of Object form, Select Floor from the Section drop-down list.

n Click once in each of the four quadrants in the plan view to draw the four floor area objects.

12. Click the Set Select Mode button  to exit Draw mode and enter Select mode.

13. 11. Click the Move Down in List button   to move the plan display down to the X-Y Plane @ Z=0.

14. Click the Draw menu > Draw 1 Joint Link command to access the Properties of Object form.  Select 
RUB1 from the Property drop-down list.

15. In the plan view of the X-Y Plane @ Z=0, click on each of the nine grid intersection points to draw nine 
Links.

16. Click the Set Select Mode button  to exit Draw mode and enter Select mode.

17. Click the drop-down list in the status bar to change the units to .

18. Click the Move Up in List button  until the plan display is moved up to the X-Y Plane @ Z=12.

19. Select all of the objects at the Z=12 level by “windowing.”

20. Click the Assign menu > Area Loads > Uniform (Shell) command to access the Area Uniform Loads
form. In that form:

n Verify that DEAD is selected from the Load Pattern Name drop-down list.

n Type 125 in the Load edit box.

n Verify that Gravity is selected in the Direction drop-down list.

n Click the OK button.

21. Select all of the objects at the Z=12 level by “windowing.” As necessary, click the Show Undeformed 

Shape button   to remove the display of gravity load applied in Step 20 and reapply the title for the 
window.

22. Click the Assign menu > Area Loads > Uniform (Shell) command to access the Area Uniform Loads
form. In that form:

n Select LIVE from the Load Pattern Name drop-down list.

n Type 100 in the Load edit box.

n Click the OK button.

23. Click the Show Undeformed Shape button  to remove the displayed load assignments.

24. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ Z=24.

25. Select all of the objects at the Z=24 level by “windowing.”

26. Click the Assign menu > Area Loads > Uniform (Shell) command to access the Area Uniform Loads
form. In that form:

n Select DEAD from the Load Pattern Name drop-down list.
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n Type 75 in the Load edit box.

n Click the OK button.

27. Select all of the objects at the Z=24 level by “windowing.”

28. Click the Assign menu > Area Loads > Uniform (Shell) command to access the Area Uniform Loads
form. In that form:

n Select LIVE from the Load Pattern Name drop-down list.

n Type 20 in the Load edit box.

n Click the OK button.

29. Click the drop-down list in the status bar to change the units to . 

30. Click the Show Undeformed Shape button  to remove the displayed load assignments.

31. Click the Move Down in List button  to move the plan display down to the X-Y Plane @ Z=12.

32. Select all of the objects at the Z=12 level by “windowing.”

33. Click the Edit menu > Replicate command to access the Replicate form. In that form:

n Select the Linear Tab.

n Type -12 in the dz edit box in the Increments area.

n Verify that the Number is 1.

n Click the OK button.

34. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active.

35. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ Z=24.

36. Select all objects at the Z=24 level by “windowing.”

37. Click the Assign menu > Joint > Constraints command to access the Assign/Define Constraints form. 
In that form:

n In the Choose Constraint Type to Add area, click the drop-down list that reads Body and then 
click Diaphragm.  Click the Add New Constraint button to access the Diaphragm Constraint form. 
In that form:

¡ Type ROOF in the Constraint Name edit box.

¡ Select the Z axis option in the Constraint Axis area if it is not already selected.

¡ Click the OK buttons on the Diaphragm Constraint and Assign/Define Constraints forms to 
assign the diaphragm constraint.

38. Click the Show Undeformed Shape button  to remove the displayed constraint assignments.

39. Click the Move Down in List button  to move the plan display down to the X-Y Plane @ Z=12.

40. Select all objects at the Z=12 level by “windowing.”

41. Click the Assign menu > Joint > Constraints command to access the Assign/Define Constraints form. 
In that form:

n In the Choose Constraint Type to Add area, click the drop-down list that reads Body and then 
click Diaphragm.  Click the Add New Constraint button to access the Diaphragm Constraint form. 
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In that form:

¡ Type 2ND in the Constraint Name edit box.

¡ Select the Z axis option in the Constraint Axis area if it is not already selected.

¡ Click the OK buttons on the Diaphragm Constraint and Assign/Define Constraints forms to 
assign the diaphragm constraint.

42. Click the Show Undeformed Shape button  to remove the displayed constraint assignments.

43. Click the Move Down in List button  to move the plan display down to the X-Y Plane @ Z=0.

44. Select all objects at the Z=0 level by “windowing.”

45. Click the Assign menu > Joint > Constraints command to access the Assign/Define Constraints form. 
In that form:

n In the Choose Constraint Type to Add area, click the drop-down list that reads Body and then 
click Diaphragm.  Click the Add New Constraint button to access the Diaphragm Constraint form. 
In that form:

¡ Type 1ST in the Constraint Name edit box.

¡ Select the Z axis option in the Constraint Axis area if it is not already selected.

¡ Click the OK buttons on the Diaphragm Constraint and Assign/Define Constraints forms to 
assign the diaphragm constraint.

46. Click the Show Undeformed Shape button  to remove the displayed diaphragm constraint 
assignments.

Note:   Before defining time history functions, locate the time history files that you wish to use.  For this problem, 
we are using files named lacc_nor-1.th and Lacc_nor-2.th, but any time history files may be used.  A number of 
sample files are included with SAP2000.

47. Click the Define menu > Functions > Time History command to access the Define Time History 
Functions form. In that form:

n In the Choose Function Type to Add area, click the drop-down list that reads Sine Function and 
then click Function from File.  

n Click the Add New Function button to access the Time History Function Definition form. In that 
form:

¡ Type LACC0 in the Function Name edit box.

¡ Click the Browse button in the Function File area to access the Pick Function Data File
form. In that form:

l Locate and highlight the first time history file that you wish to use (we are using
lacc_nor-1.th).

l Click the Open button to return to the Time History Function Definition form.

¡ Type 2 in the Header Lines to Skip edit box.

¡ Type 8 in the Number of Points Per Line edit box.

¡ Select the Values At Equal Intervals of option and type .02 in the edit box.

¡ Click the OK button to return to the Define Time History Functions form.

Page 7 of 11Problem O

10/4/2018mk:@MSITStore:C:\Program%20Files%20(x86)\Computers%20and%20Structures\SAP2...



n Click the Add New Function button to access the Time History Function Definition form. In that 
form:

¡ Type LACC90 in the Function Name edit box.

¡ Click the Browse button in the Function File area to access the Pick Function Data File
form. In that form:

l Locate and highlight the second time history file that you wish to use (we are using
lacc_nor-2.th).

l Click the Open button to return to the Time History Function Definition form.

n Type 2 in the Header Lines to Skip edit box.

n Type 8 in the Number of Points Per Line edit box.

n Select the Values At Equal Intervals of option and type .02 in the edit box.

n Click the OK buttons on the Time History Function Definition and Define Time History Functions
form to close all forms.

48. Click the Define menu > Load Cases command to access the Define Load Cases form. In that form:

n Click on Modal in the Load Case Name list to highlight it.

n Click the Modify/Show Case button to access the Load Case Data - Modal form. In that form:

¡ Type 30 in the Maximum Number of Modes edit box.

¡ In the Type of Modes area select the Ritz Vectors option.

¡ In the Loads Applied area, verify that Load Pattern shows in the Load Type drop-down list 
and that DEAD shows in the Load Name drop-down list.  Click the Add button.

¡ In the Loads Applied area, select Accel from the Load Type drop-down list and UX from 
the Load Name drop-down list.  Click the Add button.

¡ In the Loads Applied area, select UY from the Load Name drop-down list.  Click the Add
button.

¡ In the Loads Applied area, select Link from the Load Type drop-down list.  Click the Add
button.

¡ Click the OK button to return to the Analysis Cases form.

n Click the Add New Case button to access the Analysis Case Data form. In that form:

¡ Type GRAV in the Analysis Case Name edit box.

¡ Select Time History from the Analysis Case Type drop-down list.

¡ Select the Nonlinear option in the Analysis Type area.

¡ In the Loads Applied area, verify that Load shows in the Load Type drop-down list and that 
DEAD shows in the Load Name drop-down list.  Select RAMPTH from the Function drop-
down list. Click the Add button.

¡ Type 100 in the Number of Output Time Steps edit box.

¡ Type .1 in the Output Time Step Size edit box.

¡ Click the OK button to return to the Define Load Cases form.

n Click the Add New Load Case button to access the Load Case Data form. In that form:
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¡ Type LAC in the Load Case Name edit box.

¡ Select Time History from the Load Case Type drop-down list.

¡ Select the Nonlinear option in the Analysis Type area.

¡ In the Initial Conditions area, select the Continue from State at End of Modal History
option.

¡ In the Loads Applied area, select Accel from the Load Type drop-down list and U1 from the 
Load Name drop-down list.  Select LACC0 from the Function drop-down list, and type 
0.0328 in the Scale Factor edit box. Click the Add button.

¡ In the Loads Applied area, select U2 from the Load Name drop-down list and select
LACC90 from the Function drop-down list. Click the Add button.

¡ Type 3000 in the Number of Output Time Steps edit box.

¡ Type .02 in the Output Time Step Size edit box.

¡ In the Other Parameters area of the form, click the Modify/Show button for Modal 
Damping to access the Modal Damping form. In that form:

l Verify that .05 shows in the Constant Damping For All Modes edit box.

l In the Modal Damping Overrides area type 1 in the Mode box, type 0.02 in the 
Damping box and click the Add button.

l In the Modal Damping Overrides area type 2 in the Mode box and click the Add
button.

l In the Modal Damping Overrides area type 3 in the Mode box and click the Add
button.

l Click the OK buttons on the Model Damping, Load Case Data, and Define Load 
Cases forms to close all forms.

49. Click the Run Analysis button  to display the Set Load Cases to Run form. In that form:

n Verify that all load cases are set to Run in the Action list.

n Click the Run Now button to run the analysis.

50. When the analysis is complete, check the messages in the SAP Analysis Monitor window and then click 
the OK button to close the window.

51. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active.

52. Click the Set Display Options button  (or the View menu > Set Display Options command) to access 
the Display Options for Active Window form. In that form:

n Check the Labels box in the Joints area.

n Click the OK button.

53. Click on the center joint, joint 13, in the plan at Z=0 to select it.

54. Click the Move Up in List button  twice to move the plan display up to the X-Y Plane @ Z=24.

55. Click on the center joint, joint 15, in the plan at Z=24 to select it.

56. Click the Set Display Options button  (or the View menu > Set Display Options command) to access 
the Display Options on Active Window form. In that form:
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n Uncheck the Labels box in the Joints area.

n Click the OK button.

57. Click the Display menu > Show Plot Functions command to access the Plot Function Trace Display 
Definition form. In that form:

n Select LAC from the Load Case drop-down list.

n Click the Define Plot Functions button in the Choose Plot Functions area to access the Plot 
Functions form. In that form:

¡ Highlight Joint 13.

¡ Click the Modify/Show Plot Function button to access the Joint Plot Function form. In that 
form:

l Verify that the Displ option is selected in the Vector Type area.

l Select the UY option in the Component area.

l Click the OK button to return to the Plot Functions form.

¡ Highlight Joint 15.

¡ Click the Modify/Show Plot Function button to access the Joint Plot Function form. In that 
form:

l Verify that the Displ option is selected in the Vector Type area.

l Select the UY option in the Component area.

l Click the OK button to return to the Plot Functions form.

¡ In the Choose Function Type to Add area select Add Base Functions from the drop-down 
list and click Add Plot Function button to access the Base Functions form. In that form:

l Check the Base Shear Y check box.

l Click the OK buttons on the Base Functions and Plot Functions forms to return to 
the Plot Function Trace Display Definition form.

¡ Click on Joint 13 in the List of Functions to highlight it (select it).

¡ Hold down the Ctrl key on the keyboard and click on Joint 15 to add it to the selection.

¡ Click the Add button to move Joints 13 and 15 into the Vertical Functions list.

¡ Click the Display button to display the displacement time histories. Note that there is very 
little difference between the 1st and roof level displacements. The structure is essentially 
moving as a rigid body on top of the isolators.

¡ Click the OK button to close the Display Plot Function Traces form and return to the Plot 
Function Trace Display Definition form.

n Click on Joint 15 in the Vertical Functions list to highlight it.

n Hold down the Ctrl key on the keyboard and click on Joint 13 to add it to the selection.

n Click the Remove button to move Joints 15 and 13 back into the List of Functions list.

n Click on Base Shear Y in the List of Functions to highlight it.

n Click the Add button to move Base Shear Y into the Vertical Functions list.

n In the Horizontal Plot Function drop-down list, select Joint 13.
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n Click the Display button to display the force-displacement plot.

n Click the OK button to close the Display Plot Function Traces form and return to the Plot Function 
Trace Display Definition form.

n Click the Done button to close the Plot Function Trace Display Definition form.

Page 11 of 11Problem O

10/4/2018mk:@MSITStore:C:\Program%20Files%20(x86)\Computers%20and%20Structures\SAP2...


